Google E-Tablolarla Not Hesaplama Nasıl Yapılır?

Google E-Tablolarla Not Hesaplama Nasıl Yapılır?
Murat UZUN
Murat UZUN nasıl yapılır
YORUM YAZ

Sütün ve satırlardan oluşan Excel türü veritabanı programlarını genellikle liste hazırlamak için kullansakta zengin komut hazinesiyle hayatımızı kolaylaştıracak pek çok özelliğe sahip. Google Drive'ın e-tablo hizmetini (Google E-Tablolar kullanarak basit bir not hesaplama programının nasıl yapılacağını anlaşılır bir biçimde özetlemeye çalıştık.

İlk Aşama: Not Hesaplama Programımızın Çalışma Prensini Belirleyelim

Programımızın çalışma sistemine karar vermek oldukça önemli. Bu rehberimizde örnek olarak vize ve final olmak üzere iki tane sınav yapıldığını varsayarak işe koyulacağız. Vize sınavının Yüzde 40'ı, Final Sınavının ise Yüzde 60'ı alınarak öğrenciye bir ortalama notu vereceğiz. Ve ortama notunun durumuna göre geçip kaldığını; geçtiyse geçme derecesini gösteren ifadeyi hücrelere yazdırmaya çalışacağız. O zaman ilk iş olarak programımızın iskeletini kabaca hazırlayalım.

Ortalamayı Hesaplamak İçin Sayıların Yüzdesini Nasıl Alırız?

Bahsettiğimiz üzere Ortalama kısmına vize sınavının yüzde 40'ını final sınavının da yüzde 60'ını yazdırmaya çalışacağız. Gözümüzün korkmasına hiç gerek yok. Bir sayıyı 0,4 ile çarpmak o sayının yüzde 40'ını almak demektir. Aynı şekilde 0,6 ile çarpmak da o sayının yüzde 60'ını almak manasına geliyor.

Öncelikle vize ve final notlarının hangi hücrede olduğunu tespit edelim.

Görüldüğü üzere vize sınavı notu A3 hücresinde bulunuyorken final sınavı notu B3 hücresinde bulunuyor. O zaman hemen Ortlama notunun olduğu hücreye geçip formülü yazmaya başlayalım. Unutmayın, her formül = (EŞİTİR) ifadesiyle başlar. Ortlamamızı almak için

=(A3*0,4 + B3*0,6) yazıp enter diyoruz. Rastgele notlar yazıp test edelim.

Ve not ortalamasını başarıyla aldık! Ama alt satıra aynı şeyi yapmak istediğimiz de aynı şey geçerli olmayacak. Onlarca öğrenci olduğunu düşünürsek bu komutu onlarca satıra uygulamamız gerekecek. Ama merak etmeyin. Bunun da bir kısayolu var. Ortalama satırının sağ alt köşesinde bir noktacık var. O noktacığı alta doğru sürüklediğimiz zaman aynı komut diğer hücrelere de uygulanacak. Örnek olarak yazdığımız notları silip, hemen denemeye başlayalım.

İşlem tamam! Böylece komutu her satıra tek tek yazmaktan kurtulduk.

"EĞER" Formülüyle 'Kaldı' ve 'Geçti' Göstermek

Oluşturduğumuz Durum satırına gelerek formülümüzü yazalım.

=EĞER(bir şart koşuyoruz;"şart sağlanırsa ne olacak";"sağlanmazsa ne olacak")

Eğer döngümüzü başlattık. Burada programa bir şart koşacağız. Ortalaması 50'den düşük ise Durum ekranın KALDI görünsün, 50 ve üzeriyse GEÇTİ görünsün. Öncelikle şart koşacağımız alan olan Ortalama satırının yerini bulalım.

Gördüğünüz üzere ortalama hücresi C3 satırında. Formülümüze kaldığımız yerden devam edelim.

EĞER döngüsünde kullanacağımız bazı operatörler ve anlamları kısaca şöyle;

> : Büyüktür

< : Küçüktür

= : Eşittir

>= : Büyük ve eşitse

<= :="" strong=""> Küçük ve eşitse

Formülümüze dönelim

=EĞER(C3<50;"kaldi";"geçti̇") strong="">

Şartımızı bu formülle koştuk. Bakalım çalışıyor mu?

Gayet güzel çalışıyor!

İç İçe Eğer Formülü Kullanarak Geçme Derecelerini Belirlemek

Bu noktada işi biraz daha karmaşık hale getirelim. Ortalaması;

0-49 arasında olanların Geçme derecesi: KALDI

50-70 arasında olanların Geçme derecesi: ORTA

70-85 arasında olanların Geçme derecesi: İYİ

85-100 arasında olanların Geçme derecesi: ÇOK İYİ

olarak Geçme Derecesi hücresinde görünmesini isteyelim.

Hemen bir ipucu paylaşalım. Örneğin 50 ve 70 arasında diye şart koşarken 50 sayısının da şarta dahil olmasını istiyorsak büyük eşit (>=) veya küçük eşit parametrelerini kullanmak durumundayız. Sisteme bu şartı koşabilmek için dört eğer formülünü iç içe kullanacağız.

=EĞER(C3 < 50;"kaldı";EĞER(C3<=69;"orta";eğer(c3 84="" yi="" ok="" iyi="" p="">

Üç adet döngüyü iç içe kullandığımız için sonuna bir değil üç adet parantez koyduk. Bakalım çalışıyor mu?

Gayet güzel çalışıyor! Sol alt köşedeki oktacığı kaydırarak bu formülü de alttaki satırlara istediğiniz gibi uygulayabilirsiniz. 

2017 YGS Puan Hesaplama Nasıl Yapılır?

YORUMLAR